X-Drive pedal: Trouble getting the USB connection to work.

AmpliTube TONEX, AmpliTube 5, AmpliTube Custom Shop, AmpliTube Joe Satriani, AmpliTube Brian May, MESA/Boogie®,Orange™, Fender™, Hendrix™, Metal, AmpliTube SVX, and more for Mac/PC

X-Drive pedal: Trouble getting the USB connection to work.

Postby GeirAamo72 » Sat Mar 05, 2022 4:58 pm

Hi all!

I couldn’t find a separate thread for the X Gear pedals, so I hope it’s okay to post the following here:

I bought my IK Multimedia X-Drive this autumn, and while it does work as a standalone pedal in front of my amp, I’m having trouble getting it to function via USB. This, in turn, is something of a let-down, as part of its appeal was to use it with the AmpliTube software for recording on my computer.

Anyway, I wanted to see if there’s anything obvious that I’ve forgotten in terms of using the unit correctly, and if anyone has useful tips with regards to this, I’d be thankful for that.

In terms of the unit itself, I’ve switched it to interface mode in the global settings and hooked it up to the computer with the supplied USB cable. I’ve tried both different USB cables and different USB ports, but the computer still claims that no X Gear unit is connected. For good measure, I’ve also tried connecting it in live mode with the various cable and port constellations mentioned above, but that makes no difference. Equally, the supplied cable works with other USB interfaces that I own, and I’ve also restarted both the unit and the computer in every combination I can think of, again without results. I have no indication that there’s anything wrong with my computer’s USB ports.

On the computer end of things, I’ve installed the ASIO driver, Amplitube 5 and the X Gear Librarian, and I’ve also authenticated and registered all the pieces of software that need that, plus the X-Drive unit itself. Both Amplitube and the X Gear Librarian insist that no X Gear unit is connected when I hook up the pedal in interface mode to the computer.

Otherwise (read: in live mode), my X Drive seems to be in working order. A couple of the presets featuring the more regular overdrive pedals come across as somewhat harsh and/or unnecessarily loud compared to the ones preceding and succeeding them, but nothing else seems particularly off to me.

Am I forgetting anything painfully obvious here in getting the X-Drive to work with my computer, or could my unit actually be partially defective? Should I be trying a factory reset? That’s the only thing I can think of that I haven’t tried…

Regards,
Geir, Norway
GeirAamo72
 
Posts: 3
Joined: Sat Mar 05, 2022 4:49 pm

Re: X-Drive pedal: Trouble getting the USB connection to wor

Postby ember447 » Sat Jun 11, 2022 6:12 am

hey! were you able to solve this problem? i'm having the same issue.
ember447
 
Posts: 2
Joined: Sat Jun 11, 2022 6:07 am

Re: X-Drive pedal: Trouble getting the USB connection to wor

Postby GeirAamo72 » Sun Jun 12, 2022 6:50 pm

Hi, Ember!

Unfortunately, no.

In addition to what I mentioned in the original message, I tried a factory reset, but the USB connection on the XDrive still won't work.

I've procrastinated getting in touch with the dealer that sold me the pedal, but it looks like it'll be the only way to get something done about it. Using the pedal as a USB interface to record guitars was one of my main motivations for buying it, so it is a major letdown that that part of the pedal simply won't work.

PS: Please do let me know if you figure this out!
GeirAamo72
 
Posts: 3
Joined: Sat Mar 05, 2022 4:49 pm

Re: X-Drive pedal: Trouble getting the USB connection to wor

Postby ember447 » Sun Jun 12, 2022 8:08 pm

Hey…i tried it on a macbook pro. It works. Was able to even update the firmware. On the PC, it shows up in the Device Manager as X-Drive but the Ik software doesn’t see it. My pc is on Windows 11. I’ll try on a windows 10 machine when i have the chance.
ember447
 
Posts: 2
Joined: Sat Jun 11, 2022 6:07 am

Re: X-Drive pedal: Trouble getting the USB connection to wor

Postby Peter_IK » Mon Jun 13, 2022 3:13 pm

Have you contacted IK Support about your issue? They'll surely be able to assist and help get you up and running.
IK Multimedia. Musicians First.
YouTube - Facebook - Twitter
Need help? Our support team will be happy to help and can be reached at this link.
From the rules: Moderator decisions are not a matter for forum discussion and are final.
User avatar
Peter_IK
Kingpin
 
Posts: 19978
Joined: Thu Nov 18, 2010 3:40 pm
Location: Everywhere

Re: X-Drive pedal: Trouble getting the USB connection to wor

Postby GeirAamo72 » Mon Jun 13, 2022 7:29 pm

Hi, Peter! It seems silly to have taken so long in doing it, but I've just emailed the IK Support now. Thanks for the prod!

Ember, I'm glad you got your X-Drive to run on the macbook pro. My PC is a Windows 10 for the moment, and I've held off installing Windows 11, but I'll get to that when I have a bit more time nearer the summer vacation. I tried the recovery procedure described elsewhere on this forum, but that made no difference with regards to waking up the USB interface. (Which it shouldn't really, either, considering that it's a procedure for X-Drives that do not power up properly.) I guess we'll see if IK Support will get back to me and bring in the cavalry! (I'll let you know if they do.) ;)
GeirAamo72
 
Posts: 3
Joined: Sat Mar 05, 2022 4:49 pm

Re: X-Drive pedal: Trouble getting the USB connection to wor

Postby Zaksoulam1 » Fri Feb 24, 2023 2:14 pm

Hi, were you able to get the usb working? I am having a similar issue with Tonex pedal. Without the usb, I am afraid the pedal is useless for me.
Zaksoulam1
 
Posts: 2
Joined: Sat Dec 24, 2022 6:34 pm

Re: X-Drive pedal: Trouble getting the USB connection to wor

Postby adamm26 » Mon Feb 27, 2023 8:43 pm

Hi All, Anyone able to solve this? Same issue for me with my TONEX pedal.
adamm26
 
Posts: 1
Joined: Sun May 18, 2014 4:31 pm

Re: X-Drive pedal: Trouble getting the USB connection to wor

Postby davmags » Wed Mar 08, 2023 9:50 pm

Any luck? I'm having the same issue. The thing is though, it did work when I first got it once. Then I upgraded the Tonex version through IK Product Manager and it no longer works. I would blame the software upgrade, however it is not even showing up anywhere anymore as a USB device
davmags
 
Posts: 1
Joined: Sat Aug 12, 2017 10:21 pm

Re: X-Drive pedal: Trouble getting the USB connection to wor

Postby flyaxe » Fri Mar 17, 2023 12:44 pm

ToneX Pedal here, no longer shows up as USB device, have tried everything I know and can think of...... I am a bit surprised at this, this is a new windows 11 pc and runs everything really nice, except this.
flyaxe
 
Posts: 2
Joined: Sat Feb 18, 2023 12:13 pm

Re: X-Drive pedal: Trouble getting the USB connection to wor

Postby jtardis » Wed Mar 22, 2023 7:47 am

Argh, same here. Everything was working fine a couple of weeks ago, I did the firmware update and been using the pedal standalone ever since.
Just plugged it back in to change some presets via the librarian and it can’t be found. I’ve tried 3 cables using the IK power supply on Mac Catalina and Win 11 - not even showing in OS let alone Tonex!
I’m waiting to hear from support, did anyone here fix it?
Bit concerned as it seems totally dead USB wise, very upsetting as it’s so new, anyone sort this out or are these devices all now dead?
jtardis
 
Posts: 3
Joined: Fri Jul 08, 2011 12:12 pm

Re: X-Drive pedal: Trouble getting the USB connection to wor

Postby Zavelow » Fri Apr 28, 2023 3:40 pm

Anyone have an easy fix for the Tonex not connecting to usb anymore, or should I contact support? Seems a few users across the various forums are having this issue as well.
Zavelow
 
Posts: 1
Joined: Fri Mar 31, 2023 2:05 am

Re: X-Drive pedal: Trouble getting the USB connection to wor

Postby jtardis » Fri Apr 28, 2023 5:12 pm

I'd contact support or return under warranty. Mine won't connect anymore but I've accepted it and still use for practice with headphones, had a few good models already in there so it's OK, not great but it works as long as I don't want to add anything new. Purchased another one that is working perfectly well (so far!) and use that in my main rig now. Good Luck
jtardis
 
Posts: 3
Joined: Fri Jul 08, 2011 12:12 pm

Re: X-Drive pedal: Trouble getting the USB connection to wor

Postby scmikm23 » Thu Aug 17, 2023 6:12 am

Peter_IK wrote:Have you contacted IK Support about your issue? They'll surely be able to assist and help get you up and running.


Do you know what is causing this? Mine just had this issue and I was able to get a replacement, but I'd like to know the cause because I don't want to have this happen again when I'm out of warranty. Is there anything we can test to see if a particular unit might be vulnerable to this particular issue? thanks.
scmikm23
 
Posts: 6
Joined: Wed Mar 08, 2023 12:36 pm

Re: X-Drive pedal: Trouble getting the USB connection to wor

Postby DarkStar » Thu Aug 17, 2023 1:47 pm

As Peter_IK suggested, the best thing to do is contact Technical Support, via the IKM web site.
----------------
DarkStar ... interesting, if true.
Inspired by ...
User avatar
DarkStar
Hero Of The Week (Moderator)
 
Posts: 8700
Joined: Fri Dec 17, 2010 5:42 pm
Location: Surrey, UK

Next

Return to AmpliTube Guitar Amp & FX modeling