Not a good start…

AXE I/O, AXE I/O Solo, iRig Stomp I/O, Guitar and Bass Audio Interfaces/Controllers, iRig Keys I/O and the iRig Keys family of MIDI controllers

Not a good start…

Postby Ramblify » Fri Jan 26, 2024 2:54 pm

I just bought the Axe I/O and plugged it in and started downloading manuals and drivers ect. It’s been an awful process, slow and the IK Multimedia webpage appears to be awful and I couldn’t download deivers + I had to restart my pc several times and it eventually worked. I still haven’t got my product working! I can’t read the manual because the page keeps spooling. I feel angry and frustrated and that I have probably made a mistake purchasing this product and brand.
Ramblify
 
Posts: 2
Joined: Fri Jan 26, 2024 2:46 pm

Re: Not a good start…

Postby Peter_IK » Fri Jan 26, 2024 4:14 pm

Sorry to hear you have had issues. Please note that once you register your AXE I/O you can download drivers and read manuals, etc directly from the IK Product Manager. I can't tell what might be the issue you're having with the IK site as I'm not seeing the same issues nor reports of it but if you continue to have issues please try different browsers, clearing cache and cookies and if you are able to the IK Support team can assist via https://www.ikmultimedia.com/contact-support/
IK Multimedia. Musicians First.
YouTube - Facebook - Twitter
Need help? Our support team will be happy to help and can be reached at this link.
From the rules: Moderator decisions are not a matter for forum discussion and are final.
User avatar
Peter_IK
Kingpin
 
Posts: 19894
Joined: Thu Nov 18, 2010 3:40 pm
Location: Everywhere

Re: Not a good start…

Postby Ramblify » Sat Jan 27, 2024 11:59 am

Peter_IK wrote:Sorry to hear you have had issues. Please note that once you register your AXE I/O you can download drivers and read manuals, etc directly from the IK Product Manager. I can't tell what might be the issue you're having with the IK site as I'm not seeing the same issues nor reports of it but if you continue to have issues please try different browsers, clearing cache and cookies and if you are able to the IK Support team can assist via https://www.ikmultimedia.com/contact-support/


Thank you for your reply, Yes I have registered my AXE i/O and it only has the download for the "IK product manage app" - which I installed. What software do I need to install to get sound to come out of my speakers?
When I go to my computer settings and select the device under 'audio' the axe is not available... under the 'other devices' it comes up as "(AXE IO) - drivers unavailable"
If I turn my speakers on and AXE on, plug a guitar into input 1 of the AXE I/O I can her guitar coming out of the speakers... Why won't my computer recognize the audio interface to play sound from my PC?
>EDIT:< I also tried to use DAW (Reason) but the (AXE I/O) drivers were also not available in the preferences.
>EDIT 2< - Ok, I've located the drivers and managed to install and get my system working!
The user manual and user experience on the website is very bad. I have had and used audio interfaces before and have some skills with this and it still took me too long to work out! If I was someone who didn't read and reread the user manual, search your website, user forums and google troubleshooters on the internet; I probably wouldn't have worked it out and I probably would have thrown it in the bin!

Why someone can't simply write in the manual or on the website or registration card - "download and install the IK product manager app" first.
Then open the app, select the "hardware tab" and select/download and install the drivers for the "AXE I/O control software app"
Ramblify
 
Posts: 2
Joined: Fri Jan 26, 2024 2:46 pm


Return to Interfaces & Controllers